The app has been functioning normally for a longer stretch of time now. We are closing this incident but continue to monitor and work with solutions to prevent similar incidents in the future.
Update
Update
The load has decreased and app status is returning to normal, but we are still looking at root causes and looking at implementing counter measures.
Update
Update
We are rolling out some throttling measures on the API and continuing investigating other possible sources of heavy load.
Identified
Identified
Our API is overloaded with requests to a specific endpoint. We are looking into the best way of fixing it.
Update
Update
Request queues are growing to deny some requests. Still investigating...
Investigating
Investigating
We are investigating long response times making the app slow...